BZOJ3275 Number <黑白染色+最小割>

Problem

Number

Time  Limit:  10  Sec\mathrm{Time\;Limit:\;10\;Sec}
Memory  Limit:  128  MB\mathrm{Memory\;Limit:\;128\;MB}

Description

NN个正整数,需要从中选出一些数,使这些数的和最大。
若两个数a,ba,b同时满足以下条件,则a,ba,b不能同时被选

  1. 存在正整数cc,使a2+b2=c2a^2+b^2=c^2
  2. gcd(a,b)=1\gcd(a,b)=1

Input

第一行一个正整数NN,表示数的个数。
第二行NN个正整数a1,a2,,aNa_1,a_2,\cdots ,a_N

Output

最大的和。

Sample Input

1
2
5
3 4 5 6 7

Sample Output

1
22

HINT

N3000N\le 3000

标签:黑白染色 最小割

Solution

两条性质:
·奇2^2+奇2^2 \ne X2(XN)X^2 (X\in N^*)
·gcd(\gcd(偶,偶)1) \ne 1
∴奇与奇共存,偶与偶共存
建模:SS\to奇 $ : val,偶,偶\to T : val,奇,奇\to$偶 :INF: INF
$ans = $ 总权值-最小割

Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include <bits/stdc++.h>
#define MAX_N 3000
#define INF 2147483647
using namespace std;
int n, s, t, sum, cnt, a[MAX_N+5], d[MAX_N+5], pr[MAX_N+5];
struct node {int u, v, c, nxt;} E[MAX_N*100];
int gcd(int x, int y) {return y ? gcd(y, x%y) : x;}
void init() {s = 0, t = n+1; memset(pr, -1, sizeof pr);}
void insert(int u, int v, int c) {E[cnt].v = v, E[cnt].c = c, E[cnt].nxt = pr[u], pr[u] = cnt++;}
void addedge(int u, int v, int c) {insert(u, v, c), insert(v, u, 0);}
bool BFS() {
queue <int> que; que.push(s);
memset(d, -1, sizeof d), d[s] = 0;
while (!que.empty()) {
int u = que.front(); que.pop();
for (int i = pr[u]; ~i; i = E[i].nxt) {
int v = E[i].v, c = E[i].c;
if (!c || ~d[v]) continue;
d[v] = d[u]+1, que.push(v);
}
}
return ~d[t];
}
int DFS(int u, int flow) {
if (u == t) return flow;
int ret = 0;
for (int i = pr[u]; ~i; i = E[i].nxt) {
int v = E[i].v, c = E[i].c;
if (!c || d[v] != d[u]+1) continue;
int tmp = DFS(v, min(flow, c));
E[i].c -= tmp, E[i^1].c += tmp;
flow -= tmp, ret += tmp;
if (!flow) break;
}
if (!ret) d[u] = -1;
return ret;
}
int Dinic() {int ret = 0; while (BFS()) ret += DFS(s, INF); return ret;}
bool chk(int i, int j) {return gcd(a[i], a[j]) == 1 && sqrt(a[i]*a[i]+a[j]*a[j]) == floor(sqrt(a[i]*a[i]+a[j]*a[j]));}
int main() {
scanf("%d", &n), init();
for (int i = 1; i <= n; i++) scanf("%d", a+i), sum += a[i];
for (int i = 1; i <= n; i++)
if (a[i]%2) addedge(s, i, a[i]);
else addedge(i, t, a[i]);
for (int i = 1; i <= n; i++) for (int j = 1; j <= n; j++)
if (a[i]%2 == 1 && a[j]%2 == 0 && chk(i, j)) addedge(i, j, INF);
return printf("%d", sum-Dinic()), 0;
}